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ABSTRACT

The increasing demand of computer communication networks are growing rapidly day by day. With the
growing need to distribute applications across multiple networks and the availability of high capacity,
high-performance intermediate switching nodes, and networks, an efficient routing mechanism has
become the core requirement. This research primarily focuses on the design and performance of routing
information protocol by using OPNET. This allows multiple Ethernet point-to-point links to be bundled
into one logical full-duplex channel for Fast Ethernet (10BaseT, 100BaseT, or 1000BaseX). These
applications require some QoS support such as guaranteed bandwidth, less delay, less jittering effect and
low error rate. This network model is based on OPNET IT GURU Academic Edition. This OPNET
simulation showed the impact of IP routing protocol for hybrid networks for different types of
applications. OPNET simulation tool is used to design the network; analysis of the results is examined
using standard tools.
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1. Introduction

Most important aspect of communication is routing and routing is done by routing protocols. The
objective of this project is to configure and analyze the performance of Routing Information Protocol
(RIP) model. We will set up a network that utilizes RIP as the routing protocol. We will analyze the
routing tables generated in the routers and observe how RIP is affected by link failures.

After briefing the introduction in section I, Section II Background, section III covers the scenarios we
tested, section IV analyses the results and the conclusion is drawn in section V.

2. Background

RIP (Routing Information Protocol) is known as dynamic routing protocol and it was come in the field of
routing in 1988 of June and its reference is RFC 1058.1t was developed by C. Hedrick from Rutgers
University.RIP is a routing protocol for exchanging routing table information between routers. Routing
updates must be passed between routers so that they can make the proper choice on how to route a
packet.Main goal was to be a robust protocol for routing within an autonomous system. RIP always uses 1
as link metric and straight forward implementation of Distance Vector Routing or a simple intradomain
protocol. Each router advertises its distance vector every 30 seconds (or whenever its routing table
changes) to all of its neighbors and maximum hop count is 15, with “16” equal to “e”, Or Routes are
timeout (set to 16) after 3 minutes if they are not updated.

Routing is done differently within an autonomous system (intradomain routing) and between autonomous
systems (interdomain routing).An autonomous system is a region of the Internet that is administered by a
single entity.

During this research we use OPNET simulator IT GURU Academic Edition V9.1, Optimized Network
Engineering Tools (OPNET) Modeler is the industry’s leading simulator specialized for network research
and development. It allows users to design and study communication networks, devices, protocols, and
applications with great flexibility. OPNET is a simulator built on top of a discrete event system (DES). It
simulates the system behavior by modeling each event happening in the system and processes it by user-
defined processes. It uses a hierarchical strategy to organize all the models to build a whole network.

3. Implementation

In this section, we will discuss the breakdown of the project implementation from initiating the topologies
to setting various protocol and simulation parameters. In the following sections, we will present the
obtained simulation results and compare the performance of the RIP. In order to Compare No_Failure
Scenario or Failure Scenario is given below.

3.1. No_Failure Scenario creation
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1))
2)

3)

Start OPNET IT Guru—> Choose File> New from the file menu->Select Project and
Click OK

Enter the name of the project to be Prashant_RIP, and the scenario to be NO_Failure
and Click OK

In the Startup wizard:

Initial Topology Dialog box—> Create Empty Scenario is selected—> Click Next
Network Scale List = Select Campus—> Click Next three times—> Click OK

3.2. Creating and Configuring the Network

1))

2)
3)

The network shmllld appear as below:

4)

5)

Add two 100BaseT_LAN objects and one ethernet4_slip8_gtwy router to the project
workspace.

Connect the two LAN objects with the router using 100BaseT links.

You can do so by right-clicking on the object and selecting “Set Name”-> close the
Object Palette Dialog box—> Save your Project
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Fig.1 Network Design
Right-click Router] >Edit Attributes = Expand the “IP Routing Routers” hierarchy
and set the value of “Routing Table Export” to Once at the end of thesimulation.
Make three more copies and make sure that your network look like this

Use PPP_DS3 links to interconnect the router
&l ) Failure_[Subnet: top.C: -7Ea
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Fig.2 No_failure scenario Network

3.3. Choosing the Statistics

1))

Right-click on the project workspace and select “Choose Individual Statistics” then
e  Global Statistics 2RIP —>Traffic Sent (bits/sec)

e  Global Statistics 2RIP = Traffic Received (bits/sec)

e Nodes Statistics = Route Table - Total Number ofUpdate

Click OK and then save your project.

3.4. Configuring the Simulation
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1) Click on the run simulation icon ->Configure Simulation window should appear = Set

the duration of the simulation to be 10 minutes.

2) Click on the Global Attributes tab and change the following attributes as shown below:

(i) IP Dynamic Routing Protocol = RIP

(ii)IP Interface Addressing Mode = Auto Addressed / Export

(iii) RIP Sim Efficiency = Disabled

{If the RIP Sim Efficiency is enabled, then RIP will stop after the “RIP Stop Time”. But, we need RIP to

keep updating the routing table in case there is any change in the network.}
Click Ok and then save the project.
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Fig.3 Simulation of No_failure Scenario Network

In the network we just created, the routers will build their routing tables and then they will notneed to

update them further because we did not simulate any node or link failures.
3.5. Failure Scenario creation

In this scenario, we will simulate failures so that we can now compare the behavior of the

routersin both the cases.

1) Scenarios > Duplicate Scenario > name it Failure>Click OK

2) Add a Failure Recovery object to the workspace, select utilities from the drop down
menu and name it Failure as shown below:

3) Right-click on the Failure object and select “Edit Attributes”

4) Expand the Link Failure/Recovery Specification hierarchy and set rows to 1. Set the

attributes of the added row as shown below:
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Fig.4 Failure Scenario Network
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Fig.5 Attributes of Failure Scenario Network

Click Ok and then save the project-> Run Simulation for the duration of 10 minutes as before.
v" Now Let us compare the Result
a) Right click on the project workspace —> Compare Results—=> Campus

Network—=>Router1 = Route Table=> Total number of updates = Click Show =D right-click and
change “Draw Style” to Bar
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Fig.6 Results Compare
b) Capture the figure using PrntScrn.
) Likewise, obtain figures for the total number of updates at all the other routers.

4. Result Analysis

In No failure scenario, it shows that routing table we created will build their routing table with no
update tables as there is no link failure therefore, the routing table is smooth as show in the above part of the fig.

In Failure scenario, we created a link failure where more traffic is sent and set time is 200 seconds to
fail the simulation (200 second equal to3minutes and 20 seconds). In result the RIP in effected nodes send out an
update of their routing table to place that failure.

For further data traffic and update, we find the IP address of the routers for OPNET interface.
4.1. Obtain the IP addresses of the interface

Before checking the contents of the routing tables, we need to determine the IP address
information for all interfaces in the current network. Recall that these IP addresses are assigned

automatically during simulation, and we set the global attribute IP Interface Addressing Mode to export
this information to a file.

1) Select the File menu. Choose Model Files > Refresh Model Directories.

2) From the File menu, choose Open.

3) Instead of “Project”, select “Generic Data File” from the pull-down menu.

4) Select the Prashant_RIP-No_Failure-ip_addresses (Note that the other file createdfrom
the Failure scenario should also contain the same information). Click OK.

5) The following is a part of the gdf file. It shows the IP addresses assigned to all

interfaces in the network.
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File Edit Options Windows Help
# =
# Purpose:  Contains IP address information for all active =
# interfaces in the current network model,
H (created by exporting this information from the model.)
#

# Node Name: Campus Network.Net_1
e If:

0 Campus Network.Net_1 <-> Router 1

.0 Campus Netnork.Router 1 <-> Net_2

Campus Network.Net_1 <-» Router 1
Campus Network.RouTer 1 <-» Net_2
Campus Netnork.Router 4 <> Router
Campus Network.Router 1 <-» Routel

# Iface Nam ace Index IP Address Subnet Mask comnected Link
#

F0 0 192.0.0.1 255.255.255.
# Node Name: Campus Network.Net_2
# Iface Name Iface Index IP Address Subnet Mask connected Link
#

F0 0 192.0.1.1 255.255.255
# Node Name: Campus Network.Router 1
# Iface Name Iface Index IP Address Subnet Mask connected Link
#

F0 0 192.0.0.2 2355.255.255.0

IF1 1 192.0.1.2 2355.255.255.0

IF10 10 192.0.2.1 255.255.255.0

TF11 11 192.0.2.1 355.255.255.0

Loopback 1z 192.0.4.1 255.255.255.0

# Node Name: Campus Network.Net_3

Not connected to any 1ink.

0 Campus Network.Net_3 <-> Router 2

0 campus Network.Router 2 <-» Net_4

Campus Network.Net_3 <-» Router 2
Campus Netnork.Router 2 <> Net_4
Campus Network.Router 3 <-» RoUTel

# Iface Name Iface Index IP Address subnet Mask Connected Link
+

1F0 ] 192.0.5.1 255.255.255.
# Node Name: Campus Netnork.Net_4
# TIface Name Iface Index IP Address Subnet Mask Connected Link
#

1F0 [ 192.0.6.1 255.285.255.
# Node Name: Campus Network.Router 2
# Iface Name Iface Index IP Address Subnet Mask Comnected Link
#

1F0 0 192.0.5.2 255.285.255.0

IFL 1 192.0.6.2 255.255.255.0

IF10 10 192.0.7.1 255.255.255.0

IF1L 11 192.0.3.2 255.255.255.0

Loopback 12 192.0.8.1 255.255.255.0

# Node Name: Campus Network.Net_S
# Iface Name Iface Index
#

IP Address

Subnet Mask

Campus Network.Router 1 <-> Router
Not connected to any Tink.

Connected Link

F0 0

4 Nnda wamas Camais Marwarl war €

192.0.9.1

355,255,255,

0 campus Network.Net_S5 <-» Router 3

N

6)

Fig.7 No_failure IP addresses
Now let us check the contents of router R1 in both scenarios:

Open Results menu. Select “Open Simulation Log”. Expand the hierarchy as

shownbelow and click on the field “COMMON ROUTE TABLE”.

7
8)
9)

open Results menu.

10)

You will get the Routing table at Router1. Print the text file.
Repeat the above process for all the four routers and print their routing tables.
Then, go to the Failure Scenario (by selecting Scenarios—> Switch Scenario) and then

Now, try to get the routing tables for the four routers in this scenario. Print them.
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Simulation Lng(Pmshantj Time‘Ev .‘Node ‘[_‘3[5 ‘Mas&age j File Edit Options
Uﬂategnnes 600 20... Campus Network... Res... I () ‘ﬂgﬂ%@ﬂ
lasses o
b 600 20... Campus Nework... Res... COMMON ROUTE TABLE snapshotfor: | (..)
P 600 20... Campus Network... Res... COMMON ROLITE TABLE snapshot for. | (.) L COMMON ROUTE TABLE snapshot for:
600 20... Campus Network... Res... COMMON ROUITE TABLE snapshot f . g
Route Table s e J sl | [.) 1 Router name: Campus Network.Router 1
i at time: 600.00 seconds
s
£ ROUTE TABLE contents:
7
H Dest, Address  subnet Mask Next Hop Interface Name
Metric Protocol  Insertion Time
3
]
1 192,0.0.0 265.255.255.0  192.0.0.2 1F0
0 Direct | 0.000
il 192.0.1.0 255.255.255.0  192.0.1.2 IF1
irect 2
u 192,0.2,0 255.255.255.0  192.0.2.1 1IF10
irect .
u 192.0.3.0 255.255.255.0  192.0.3.1 IF1L
0 Direct 0.000
15 192,0.4.0 265.255.255.0  192.0.4.1 Loopback
0 Direct 0.000
16 192.0.11.0 285.255.255.0 192.0.2.2 1IF10
bl 5.000
i 192.0.13.0 255.255.255.0  192.0.2.2 IF10
1 5.000
it 192,0.14.0 265.255.285.0  192.0.2.2 IF10
1 RIP 5.000
9 192.0.15.0 255.255.255.0  192.0.2.2 IF10
n 192,0.5.0 265.255.255.0  192.0.3.2 IF1L
1 192.0.6.0 255.255.255.‘0 192.0.3.2 IF1L
1 RIP 5.000
b3 192,0.7.0 265.255.285.0  192.0.3.2 IF1L
1 5.000
p:| 192.0.8.0 285.255.255.0 192.0.3.2 IF1L
fk 5.000
n 192.0.9.0 255.255.255.0  192.0.2.2 IF10
2 7.310
% 192,0.10.0 265.255.255.0  192.0.2.2 IF10
2z RIP 7.310
b3 192.0.12.0 255.255.255.0  192.0.2.2 IF10
2z RIP 7.310
n
8 The gateway of last resort is not set
v M| IR
i | Ol _>|J 2 o ; .
i NOTE: In order to view the individual routing tables maintained
n by various dynamic routing protocols (e.g., OSPF and RIP), you
et columns o dislay n Suboass view n can set the simulation attribute "IP Rnurirllg Table Ekpnrt?lmpnrt"
u to "Export" to generate a network-wide routing table/protocol output.
Time VEet [V Node ﬂJ i
Cdegoy  ["Class [ Subolass Close [ [Line: 11

Fig.8 Routing With IP Addresses

5. Conclusion

Conclusion The research paper the RIP updates process and when fail node updates occurred in the network
topologies. RIP (Routing information protocol) commonly used protocol in networking. During this
research work, accessible the comparative study of elected protocol RIP and OPNET. Proportional
investigation conducted for real time data by using RIP protocol within same network. In simulation
environment specific parameters has been set for check performance of routing protocol especially RIP.
Network topology called three tires has been used.RIP implements the split horizon, route
poisoning and hold down mechanisms to prevent incorrect routing information from being propagated.
These are some of the stability features of RIP. It is also possible to use the Routing Information Protocol
with Metric-Based Topology (RMTI)algorithm to cope with the count-to-infinity problem.
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